页面导航

本文编写于 181 天前,最后修改于 131 天前,其中某些信息可能已经过时。

第三篇 如何进行运算

  • 这篇教大家如何在易语言里进行加减运算,并制作一个简单的计算器
    首先来到我们的窗口界面,创建以下组件 一个编辑框 一个按钮 然后记住我们的编辑框的名称

图1

然后双击按钮,来到程序集页面

图2

创建两个变量 可以任意命名 我这里命名为 数1 数2 类型为整数型 然后在创建一个变量 命名为 分割后文本 类型为文本型 然后在 数组上填个0 最后在创建 返回值 变量

图3

开始编写代码

.版本 2

.如果真 (倒找文本 (编辑框1.内容, “+”, , 假) ≠ -1)
    分割后文本 = 分割文本 (编辑框1.内容, “+”, )
    数1 = 到整数 (分割后文本 [1])
    数2 = 到整数 (分割后文本 [2])
    返回值 = 到文本 (数1 + 数2)
    编辑框1.内容 = 返回值
    返回 ()
.如果真结束
.如果真 (倒找文本 (编辑框1.内容, “-”, , 假) ≠ -1)
    分割后文本 = 分割文本 (编辑框1.内容, “-”, )
    数1 = 到整数 (分割后文本 [1])
    数2 = 到整数 (分割后文本 [2])
    返回值 = 到文本 (数1 - 数2)
    编辑框1.内容 = 返回值
    返回 ()
.如果真结束
.如果真 (倒找文本 (编辑框1.内容, “*”, , 假) ≠ -1)
    分割后文本 = 分割文本 (编辑框1.内容, “*”, )
    数1 = 到整数 (分割后文本 [1])
    数2 = 到整数 (分割后文本 [2])
    返回值 = 到文本 (数1 × 数2)
    编辑框1.内容 = 返回值
    返回 ()
.如果真结束
.如果真 (倒找文本 (编辑框1.内容, “/”, , 假) ≠ -1)
    分割后文本 = 分割文本 (编辑框1.内容, “/”, )
    数1 = 到整数 (分割后文本 [1])
    数2 = 到整数 (分割后文本 [2])
    返回值 = 到文本 (数1 ÷ 数2)
    编辑框1.内容 = 返回值
    返回 ()
.如果真结束
编辑框1.内容 = “运算式子错误!”

图4


给大家讲解下 倒找文本命令 以及 分割文本 命令 和 如果真命令

倒找文本 就是字面上意思 在一段文本里找到和另一段文本一模一样的信息 没找到返回 -1

分割文本 在一段文本中 分割成几段文本 具体你要分割什么那看你自己了
示例: 易语言 要分割成两段文本 我选择中间词 语 然后分割出来的文本就是 易 和 言
再举例 要分割 www.autive.cn 我选择 .autive. 进行分割 分割出来的就是 www 和 cn
也可以选择 . 分割 分割出来后就是 www autive cn 这三段文本

由于分割文本分出来的多段文字 所以需要数组变量来容纳他,所以为什么让你们在上面要把数组填上了

如果真 判断命令有很多种 例如 判断 如果 等一类的,具体看你们喜欢哪种判端命令了
上面的 如果真 (倒找文本 (编辑框1.内容, “/”, , 假) ≠ -1) 因为倒找文本返回的是整数型 所以≠号后面也要是整数型数据


运行程序

图5

图6

记住 电脑上的 乘于号 是 * 除于号 是 /

第三章结束

博主已关闭本页面的评论功能